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How to use the LogViewer2 software including shortcuts and mouse buttons.
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1 Introduction

LogViewer 2 is a software application for Windows XP and later. Its purpose is to view data log files
produced by the Proxeon Easy-nLC. It can open, view and compare several log files at the same time
and also open zip files containing log files.

There is no installer — simply unzip all the files from the downloaded archive into a suitable directory
and run the LogViewer2.exe application (by double-clicking the file or icon).

While only the LogViewer2.exe is needed for the application to run there still are a few files that can
help when style sheet files are not in the result folders.

If the file ‘easynl-batch.xslI’ cannot be in the result folder then LogViewer2 will look in its application
folder.

If the file ‘easynl-configdump.xsl’ cannot be in the result folder then LogViewer2 will look in its
application folder.

So it is a good idea to put the files ‘easynl-batch.xsl’ and ‘easynl-configdump.xsl’ in the same location
as the LogViewer2.exe.

The documentation files could also be put in this folder.
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2 Opening log files

To open a log file use ‘File->Open’ menu item or pick one from the most recent used list also from the
File menu.
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If ‘File->Open’ is used then pick a .txt file like Pump A.txt or any other file in the log folder. If the file is
a zip file then the file will be unzipped into a temp folder and the log tree will show all the log files
found in the zip file.

Open log files are shown in the log tree panel to the left of the window.
A log file can be opened directly on the HPLC if it is connected to a network. Select ‘File->Open’. In
the input field called ‘File name:’ type the IP-number or name of the HPLC like: \172.22.50.100\

then logon to the HPLC using an HPLC account and password. Then browse to the log files in the
batchLog folder.
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3 Showing log file graphs in a window

Select a log file by navigating the log tree and click the node with the log file name. Then the log file
will be opened and its graphs will be shown in a child window on the right.
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Note that if only one log file is opened then it will be shown automatically.
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4 Examine graphs in awindow

When a window opens 4 graphs are shown by default. ‘Pump A pressure’, ‘Pump A desired flow’,
‘Pump B pressure’ and ‘Pump B desired flow’.

Expand the log tree node (click +) to view the possible graphs to show in the window.

To show the other graphs click the graph name in the tree view and a checkmark (V) is shown next to
the graph name. If right mouse button is used then only that graph will be selected and all the other
will be unselected.

Click and hold right mouse button on the graphs to move the axes to view other parts of the graphs.

Note that arrow keys are not supported! And note the status bar at bottom right corner of the main
window. It shows the coordinates for the mouse cursor and zoom level of the view. Click them to
change zoom level for X or the Y axis (not supported in compare window).

The X axis is the time in hour:minutes:seconds. And the Y axis is the flow rate [nl/min], pressure [bar]
or the temperature [°Celsius].

To Zoom either left-click and drag the mouse to select a zoom area or use the mouse-wheel to zoom
in or out. If ctrl+left-click is used then the axes are stretched from the bottom left corner to the mouse
cursor. Hold down ‘Alt’ key to only zoom the Time axis. Hold down ‘Ctrl’ key to only zoom on the Y
axis.

Left-double-click the graphs (Menu item ‘Graph->Scale to Fit Window’ or Ctrl-F) to set the zoom to fit
window with Y axis of -10 to 350 or -10 to 1000 if log file is from a 1000 bar system.

Right-double-click the graphs (Menu item ‘Graph->Scale 1 to 1’ or Ctrl-T) to reset the zoom to 100%
and move the graph to zero offset.

Menu item ‘Graph->Scale To Max’ (Ctrl-M): Sets the zoom levels and offset so all the graphs can fit
into the Window. But Y axis will be set to -10 to 25000.

Menu item ‘Graph->Apply Coordinates’ can be used to apply coordinate labels on the graphs. Simply
click on the graphs and a label will be place near the closest graph at selected time. Place the cursor
above to place a label above the line and place it below if the label should be below the graph. Note
that these labels also can be placed onto graphs when left-clicking while Shift key in pressed.

These coordinates can also be given a label. Simply click a second time on the same coordinate and
an edit box will show. Enter a small text message. A text label will be shown together with the
coordinate label.

Right click to remove the last placed coordinate label.
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5 Working with more graph windows

It is possible to have many graph windows open at the same time and organize the windows like any
other MDI application with the Window menu item. ‘Close All' windows menu item has been added.
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Holding down Ctrl-key while moving a graph in one window will also move the graphs in the other
windows.

It is also possible to have two windows of the same graphs open at the same time. Simply hold down

Ctrl-key while clicking on a graph node in the tree. The second window can be used as an overview of
the first window and a gray rectangle will be shown.
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6 Comparing Graphs

Open two or more graphs and it is possible to compare them. A compare window will show the open
graphs in one and the same window.
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Simply open the graphs to compare and select the menu item called ‘Graph->Compare’ or press
Ctrl+O on the keyboard.

Now, when a graph is moved, it is also moved in the Compare Window. When moving graphs in the
Compare window then all graphs will be moved together. It is also possible to select each graph in the
compare window by selecting the graph node in the tree to the left (The blue or red node under the
‘Compare 1’ node). Then only the selected graph will move.

Please note: If ‘Alt’ key is pressed while moving then only the time axis will move! Also note that it is

possible to set each graph windows zoom levels by selecting the graph window and double-clicking
the zoom panels in the status bar!
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7 The Activities Graph

Checking the ‘Activities’ node in the Tree will show when the each method activity that happened in
the sample run.
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A ‘<’ in front of the activity name means that the activity starts before the time shown in the window.

A’>" after the activity name means that the activity ends after the time shown in the window.
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8 Showing the Command Log

Open a graph and select the menu item called

‘View->Command Log’ to view the script output
information.

A web browser window will open and show the
content with keyword highlighted.

Words like: FAIL will be colored in red.

The target pressure will also be shown at the
beginning of the file.

Page 10 of 14

i D Leaks-20101111-13205693. . iﬁ

C N O fleffc BosystemFie 17 @ A&

[ Mail [ Outlook web O] andre bogmastker

Source File : 11032.133 3\admin‘anaintenanceLog\Lealks- =
20101111-132056930 commandLog bt

.

11-11-2010 13:20:56
11-11-2010 13:20:56
11-11-2010 13:20:57
11-11-2010 13:20:57
11-11-2010 13:21:29
11-11-2010 13:21:28
11-11-2010 13:21:31
11-11-2010 13:21:31
11-11-2010 13:24:02
11-11-2010 13:24:03
11-11-2010 13:29:02
11-11-2010 13:29:02
11-11-2010 13:29:02
11-11-201013:20:02
11-11-2010 13:29:03
11-11-2010 13:29:03
11-11-2010 13:20:03
11-11-2010 13:29:03
11-11-2010 13:32:14
11-11-2010 133239
11-11-2010 13:37:14
11-11-2010 13:37:14
11-11-2010 133714
11-11-2010 13:37:39
11-11-2010 13:37:38
11-11-2010 133739
11-11-2010 13:38:32
11-11-2010 13:38:32

Script ouwtput Window:

Leaks' started

Preparing...

Pump &: Refilling. .

Pump B: Refilling...

Checking Pump B at 25.0 bar:

Pump B: Building pressure...

Checking Pump & at 250 bar:

Pump &: Building pressure...

Pump B: Detecting flow loss. .

Pump &: Detecting flow loss...

Pump B: Flow loss = 307 .0 olfmin

Pump B: Flow loss < 400.0 nlfmin - PAZS!
Checking Pump B at 9800 bat:

Pump B: Building pressure...

Pump &: Flow loss = 17.2 olfmin

Pump A Flow logs < 4000 nlfmin - PASS
Checking Pump A at 920.0 bar:

Pump &: Building pressure...

Pump &A: Detecting flow loss...

Pump B: Detecting flow loss. .

Pumgp & Flow loss = 14.1 olfmin

Pump A: Flow loss < 4000 nlfmin - PASE
Pump &: Refilling. ..

Pumg B: Flow loss = 1125 nlfmin

Pump B: Flow loss < 4000 nlfmin - PAZSE!
Pump B: Refilling...

Firdshing. ..

Leaks' finished

Command Log:

11-11-2010 13:20:56
11-11-201013:20:56
11-11-201013:20:56
11-11-2010 13:20:56
11-11-201013:20:56
11-11-201013:20:56
11-11-2010 13:20:56
11-11-201013:20:56
11-11-201013:20:564
11-11-2010 13:20:56
11-11-201013:20:56
11-11-201013:20:57
11-11-2010 13:20:57
11-11-201013:20:57
11-11-201013:20057
11-11-201013:20:57
11-11-201013:20:57
10112010 13:20:57

init()
Walve 3: enable()

Walve W enable()

Walve B: enable()

Walve & enable)

Pump 3: enable)

Pump B: enable)

Fump &: enable)

resumea)

OUTPUT - 'Leaks' started
OUTPUT - Prepating...

OUTPUT - Pump A: Refilling...
Walve & setPosition1-2)
OUTPUT - Pump B: Refilling...
Walve B: setPosition(]-2)

-1000 <- Pump A: setFlow(-100.0)
147.0 <- Pump A getRefill¥ olume)
1470 < Pump A pumo¥ olumer147.M s
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9 Showing the Method Parameters

Open a graph and select the menu item called
‘View->Method Parameters’ to view the batch
and method parameters used for these graphs.

/= Proxeon EASY-nLC method - " Proxeon st... E”E|E|

=] C:\BioSystemFiles|Parl V| x| |8

If no data is available then the message ‘No File Edt ‘iew Favorites Tools  Help

XML data found for Method!” will be shown. . . »
o.p Favorites | 72 & | * [CJ)BIO -

The XML file requires a XSL file to show the @ Proxeon EASY-nLC metho. . G- 5 4 »
data. Ui .

* -:/. .\:- A

If the XSL file is not found then the menu item Sample pickup

‘Graph->View Method Parameters’ is ghosted!
Volume 10.0 ul
If that is the case then the ‘easynlc-batch.xsl’ Flow 20.0 ul'min
file is missing from the application folder.

A web browser window will show the method
parameters used.

Sample loading

Volume 20.0 ul
Flow 5.0 ul/min
Mfax pressure 280.0 Bar

Gradient

Time Duration Flow |%:B
0 0 3000|350
0 600 300.0|35.0
600 (120 300.0{100.0
720|480 300.0{100.0

re-column equilibration

Volume 400 ul
Flow ot set ul'min
Max Pressurs 280.0 Bar

Analytical column equilibration

Volume 30w
Flow ot set ul'min
Max Pressurs 280.0 Bar

Autosampler wash

Flush volume 1000w
Custom wash false

Source |Volume |Cyvcles w

j My Compuker g - "'1. Q0% -

Copyright (C) 2008 Proxeon. All rights reserved.



LogViewer2 Manual

Release 2.7

10 Showing the Device configuration

Page 12 of 14

Select View->Device configuration... to view the configuration of all the devices on the Easy-nLC.

This information requires an xml file to be located along with the log files. If that is not the case then
an error message like this will show:

-
Warning

Mo XML data found for Device!

And when there is an xml file to
be used then the result window
will look like this:

e, ==

3 |#] CAProjects\LC100\Parts\Comr O ~ € X

(2 EASY-nLC Device Configur... %

{.5 n iConnect n Odense Sharepoint || Hardware =

| NEWS -

. Papers =

| Hple * £7FKS Bowling

EASY-nLC Device Configuration for L.C-009805

Cooled Autosampler (ASC) [Autosampler]|

Mamufacturer: Proxeon Biosystems A/S
Driver-info: 1.0.0
Frmware-mfo: devType:7; fwVersion36; A-001227 / devTvpe:&; fwVersion:7; T-001322
Physical-id: A-001227
Properties
cooler-temperature 7.0
cooler address 50
manipulator. address | 40
needle-vohmme 10.25
rack positions 0:6x8x1,.1:1x6x1

EASY-nL.C™ [HPLC]

Manufacturer: Proxeon Biosystems A/S
Driver-info: 3121
Firmware-info: 03-13-2012 1430
Physical-id: LC-009803
Properties
editor-max-pressure | 980
idlebleed-flow 0
idlebleed-mix 50
load-speed-protection | false
loop-volume 200
no-intelliflow false
no-precolumn false
Counters
samplesStarted 14270
samplesCompleted 12780
precolumnSamples 187.0
anacolmmnSamples 12780

m
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11 Changing line colors
To change the color of a graph select the Graph->Change Line Color.

Now click on the line which color should be changed. A color picker dialog will be shown and there will
be an arrow next to the line name in the tree view. Select the color and click ‘OK’ to change to that
color.

To use these new colors as default select the menu item called ‘Graph->Set As Default Profile’. New
graphs will now use these colors when loaded.
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12 Select graphs to view

To show the other graphs left click the graph name in the tree view and a checkmark (V) will become
visible next to the graph name. Right click and only that graph will be shown.

To set these as selected by default, select the menu item called ‘Graph->Set As Default Profile’. The
graphs will now be visible by default when loaded.
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